TS-Doctor 2.0 www.cypheros.de

Autor Thema: MAM gönnt sich ja sonst nix...  (Gelesen 490 mal)

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
MAM gönnt sich ja sonst nix...
« am: Juli 09, 2019, 19:42:30 »
 ;D
Im Vorgriff auf den neuen Rechner hab ich mir schon mal sonne AMD Radeon™ RX 5700 XT 50. Geburtstag-Edition gegönnt.

Gibts nur direkt auf der AMD Webseite, aber ACHTUNG!
Die Preise werden zwar in € ausgewiesen, 8,61€ Porto & Verpackung erscheinen auch noch tolerabel, aber GANZ AM ENDE knallen die da noch so über 80€ Mehrwertsteuer drauf!
So kommt man dann auf einen Gesamtpreis von ~487€ !

Der Schock sitzt dann doch etwas tief, zumal man an der Stelle schon durch den PayPal Teil durch ist und eigentlich keine Chance mehr hat, einen Flunsch zu ziehen.

(Wer noch einen Haken extra macht und den Preis knapp verdoppel will, kriegt auch da son 12kernigen Ryzen geliefert. Aber MAM wartet auf den "richtigen" mit 16 Kernen...)

Lächle! Du kannst sie nicht alle töten!

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #1 am: Juli 11, 2019, 17:02:29 »
GraKa da, etwas seehr pompös verpackt (und mit Unterschrift der Scheffine auf dem Kühlkörper), Lieferung per DHL Express am frühen Morgen.

Mein Schwippneffe bestand auf Auspacken, Photo machen und schließlich auf Einbau! (Ich wollte das Teil ja bis Oktober in den Schrank legen und erst im neuen Rechner einsetzen)

Grundsätzlich ging Alles, allerdings kam er hoch und kannte die Karte nicht. Auf som 4k Monitor macht sich "Microsoft Basic Display Adapter" (aka "VGA" ohne Extras) nicht wirklich gut, man tastet sich fast blind durchs Desktop und wird stark an die guten alten SNES Zeiten erinnert, so erschlagen einen die riesigen Lettern auf dem Schirm.

Es erwies sich, dass der AMD Treiber von letzter Woche deutlich veraltet war und ein komplett neues Release benötigt wurde.

Das hat er sich dann auch runtergeladen, wollte einmal komplett neu booten um den alten Treiber loszuwerden. Anschließend kam wieder SNES, aber nach der Anmeldung lief dann die Installation weiter und nach 69% und ein paar PLINGS (Device found Sound) schaltete dann das Desktop um auf die gewohnte 4k Auflösung.

Erstmal durchatmen  ;D

Allerdings hielt die Freude nicht lang an, der Start ein paar alter, aber liebgewonnener, Spiele scheiterte kläglich. Fallout New Vegas schmiss mir nur ein verächtliches "failed to initialize renderer" entgegen, Civilization beyond Earth fand mich keinerlei Meldung würdig, es startete gar nicht mehr.

Relativ neue Spiele funktionieren hingegen einwandfrei. Assassins' Creed Odyssee zum Beispiel macht satte 42fps in voller 4k Auflösung und hoher Detailstufe. HDR hab ich noch nicht probiert, aber das folgt noch irgendwann.

Was mich aber wirklich traurig stimmt: DER DOC GEHT AUCH NICHT MEHR!  >:(

Ein Öffnen (mehr wohl der Versuch desselben) des Schnittfensters reisst ihn gnaden- und kommentarlos in den Abgrund, er verschwindet sofort und vollständig.

Sach Scheffe, wo finde ich die Crashlogs und was tue ich dagegen???

16:33:38.100: OS: Windows 10 Build 18362 x64
16:33:38.100: Graphic card: AMD Radeon RX 5700 XT 50th Anniversary (DISPLAY3) aticfx32.dll 26.20.13001.9005
16:33:38.100: Resolution  : 3840 x 2160 (32Bit) 144 DPI
16:33:38.100: Monitors    : 1
16:33:38.100: Video type  : H.264
16:33:38.100: Video size  : 1920 x 1088
16:33:38.653: Cypheros TS Doctor 2.2.21
            : DirectX Version: 12.0
            : Selected audio filter: LAV Audio Decoder
            : Selected video filter: LAV Video Decoder
            : Selected Mpeg splitter: Haali Media Splitter (AR)
16:33:38.654: File: \\vcr\TV\Hautnah - Drama.ts
16:33:38.654: INIT PLAYBACK
16:33:38.654: Creating playback thread
16:33:38.674: Successfully created Graph Builder
16:33:38.684: Successfully created Media Control
16:33:38.705: Successfully created Media Event
16:33:38.725: Adding filters to the graph
16:33:38.746: Try to add FileSource TS-Doctor Filesource
16:33:38.767: Successfully created new filter TS-Doctor Filesource
16:33:38.787: Successfully queried file source
16:33:38.807: Control interface TS-Doctor Filesource assigned
16:33:38.869: Successfully loaded file
16:33:38.889: Successfully added TS-Doctor Filesource to graph
16:33:38.910: FileSource TS-Doctor Filesource added
16:33:38.930: Enumerating filters: found 31 categories
16:33:38.996: Loading filter Haali Media Splitter (AR) and adding to graph successfully completed
16:33:39.039: Loading filter LAV Video Decoder and adding to graph successfully completed
16:33:39.059: Loading filter LAV Audio Decoder and adding to graph successfully completed
16:33:39.080: Loading filter Enhanced Video Renderer and adding to graph successfully completed
16:33:39.083: Getting EVR display control
Das steht unter "zeige DirectX Log" (DX Version ist 12.0)

Ok, mit "Videorenderer" auf "TS Doc renderer" statt AUTOMATIC gehts wieder. "Windwows Default (Merit)" gibt nur schwarze Bilder, "Video Renderer" hängt den Doc völlig weg (Kill per Taskmanger benötigt), "Haali Renderer" bringt wieder den schwarzen Mann im Kohlenkeller,"Enhanced Video Renderer" den von AUTOMATIC bekannten sofortigen Totalabflug.

Also nur noch "TS Doc Renderer" funktioniert noch! etwas Einsam, nicht?

Ich häng mal n Log von nem erflogreichen Durchlauf mit dem Doc Renderer dran, vielleicht kriegt Scheffe ja irgendwelche Erkenntnisse

Lächle! Du kannst sie nicht alle töten!

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7636
    • Profil anzeigen
    • Cypheros Software Seite
Re: MAM gönnt sich ja sonst nix...
« Antwort #2 am: Juli 11, 2019, 20:26:30 »
TS-Doctor Video-Renderer ist der einzige, der keine Video-Beschleunigung, kein Direct2D, kein DirectX (Surfaces), kein MMX verwendet. Da werden die Pixel noch schön gemütlich auf eine Bitmap gemalt, pures GDI. Ist eigentlich für Linux und MACOS gedacht, wo mit Wine der DirectX-Krempel auch nicht richtig funktioniert.

Ich denke mal die Treiber sind im Bereich Grafikgeschleunigung noch nicht ganz ausgereift. AMD braucht leider immer etwas länger mit stabilen Treibern. Vielleicht war das kein schlechte Idee die Karte bis Oktober in den Schrank zu legen ;-)

Ich denke nicht, dass ich da was dran drehen kann.

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #3 am: Juli 11, 2019, 20:40:54 »
TS-Doctor Video-Renderer ist der einzige, der keine Video-Beschleunigung, kein Direct2D, kein DirectX (Surfaces), kein MMX verwendet. Da werden die Pixel noch schön gemütlich auf eine Bitmap gemalt, pures GDI. Ist eigentlich für Linux und MACOS gedacht, wo mit Wine der DirectX-Krempel auch nicht richtig funktioniert.
Na ja, zumindest hilft er bei solchen Problemen. Wer braucht hier schon Video-Entschleunigung? Schließlich steppt man ja nur in kleinen Häppchen durch den Film. Da ist es wichtiger, verlässlich die richtige Stelle zu finden. Beschleuniger sind hier meist nur störend.

Zitat
Ich denke mal die Treiber sind im Bereich Grafikgeschleunigung noch nicht ganz ausgereift. AMD braucht leider immer etwas länger mit stabilen Treibern. Vielleicht war das kein schlechte Idee die Karte bis Oktober in den Schrank zu legen ;-)
Jo, dünkt mich auch so. Ich teste noch mal was so alles geht (und was nicht mehr), dann wird wieder geswappt. Oder ich pack die alte mal spaßeshalber dabei und schaue, was passiert.

Zitat
Ich denke nicht, dass ich da was dran drehen kann.
War auch nicht so gemeint/erhofft. War mehr als Info und Warnung gedacht.
Der Doc ist auch in guter Gesellschaft, auch VLC und viele andere Direct X Programme versagen kläglich. Da muß man dann immer auf OpenGL oder andere Schnittstellen ausweichen.
Nur DirectX 12 scheint einwandfrei zu zucken, habe inzwischen auch mal Assassins Creed in HDR probiert. Geht, sieht aber potthässlich aus (völlig überstrahlt, der Himmel hat gar keine Zeichnung mehr. Dafür ist es in düsteren Katakomben/Höhlen nun sehr detailreich)

Die Karte (bzw der Treiber) muß offensichtlich noch etwas auf die Weide. Spassigerweise scheint die Hotline überlastet, man kann keine Bugreports einsenden  ;D
Lächle! Du kannst sie nicht alle töten!

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #4 am: Juli 14, 2019, 09:07:24 »
also, nachdem sich immer mehr das Grauen des Nicht-mehr-Funktionierens von Spielen und Anwendungen dargestellt hat, ist die Karte erstmal wieder ausgebaut und in den Schrank gelegt worden.

Im derzeitigen Zustand kann man nur eindeutig vom Kauf abraten, die Hardware scheint gut zu sein, die Software hingegen ist mit der heißen Nadel gestrickt und indiskutabel.

Vielleicht schicke ich das Dingen sogar wegen Nichtfunktion zurück...
Lächle! Du kannst sie nicht alle töten!

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7636
    • Profil anzeigen
    • Cypheros Software Seite
Re: MAM gönnt sich ja sonst nix...
« Antwort #5 am: Juli 14, 2019, 17:54:00 »
Läuft in 2 bis 3 Monaten vermutlich besser und ist dann auch billiger.

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #6 am: Juli 14, 2019, 18:01:09 »
Läuft in 2 bis 3 Monaten vermutlich besser und ist dann auch billiger.
Teil A würde ich ja zustimmen, aber billiger sicherlich nicht. Eher "ausverkauft". Das ist die handverlesene Spezialversion, die nicht im normalen Handel ist.
Lächle! Du kannst sie nicht alle töten!

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix... (GELÖST!)
« Antwort #7 am: Juli 15, 2019, 09:58:44 »
GELÖST!

Der Fehler steckt nicht im Treiber, sondern im AMD Setup/Update.

Wenn man zuvor schon eine AMD Karte hatte, so lädt das Update zwar den neuen und korrekten Treiber runter, bei der Installation wird aber der Direct(X/3D) Part übersprungen. Somit zeigen diese Verweise immer noch auf die alte, nicht mehr vorhandene, Karte. Deshalb "Device not available" Fehler.

Um das Problem los zu werden, ist leider etwas Stress angesagt, es ist gar nicht so einfach, den alten Treiber wieder restlos zu entfernen, so dass das Setup dann wirklich ALLES installiert.

Dazu hilft das Tool "DDU" (Display Driver Uninstall), das allerdings vordringlich darum bittet, im Safe Mode von Windows ausgeführt zu werden. "Früher" kam man da beim Booten mit F8 recht einfach hin, aber in Zeiten von UEFI ist alles etwas schwieriger. Wer sich nicht die Finger wundkloppen will damit er beim Booten zufällig den richtigen Zeitpunkt erwischt (bei Quickboot ist die Tastatur meistens noch gar nicht an, so dass man gar keine Chance hat), startet Windows normal, meldet sich nicht an, sondern wählt auf dem Startbildschirm "Neustart" aus UND HÄLT BEIM MAUSKLICK DIE SHIFT TASTE FEST. Dann erscheint ein Menü und man kann sich über Problemlösungen und noch ein paar Untermenüs zum Safe Mode vorhangeln.

Lästig, aber machbar.

Nachdem der alte Treiber restlos weg ist, kann man das normale AMD Setup durchlaufen lassen, danach funktioniert alles, wie gewohnt/gehofft/erwartet.

Ich nehme mal stark an, die werden Ihr Setup/Update bald ändern, den inzwischen melden sich viele Leute, die auf den Bug reingefallen sind.

Lächle! Du kannst sie nicht alle töten!

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7636
    • Profil anzeigen
    • Cypheros Software Seite
Re: MAM gönnt sich ja sonst nix...
« Antwort #8 am: Juli 15, 2019, 10:09:11 »
Da muss man auch erstmal drauf kommen. Ich würde ja sagen, danke für den hilfreichen Tip aber ich fürchte du bist hier weit und breit der einzige mit der Karte und wirst es vermutlich auch bleiben.

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #9 am: Juli 15, 2019, 10:36:23 »
Da muss man auch erstmal drauf kommen. Ich würde ja sagen, danke für den hilfreichen Tip aber ich fürchte du bist hier weit und breit der einzige mit der Karte und wirst es vermutlich auch bleiben.
Na ja, das passiert auch bei den "normalen" 5700er (XT) Karten. Es werden also noch einige auf diesen Schrubber brummen.
Lächle! Du kannst sie nicht alle töten!

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix... (Nachtrag)
« Antwort #10 am: Juli 17, 2019, 07:06:30 »
Heute morgen kam das erste Treiberupdate.

Automatisch einspielen lassen, DANACH WAR ALLES WIEDER IM A§$%!!!

Also, die ganze Prozedur von vorne, alten Treiber mit DDU entsorgen, reboot, neuen Treiber komplett neu installieren, alles wieder ok...

Kein Vertrauen in automatische Updates!!!
Lächle! Du kannst sie nicht alle töten!

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7636
    • Profil anzeigen
    • Cypheros Software Seite
Re: MAM gönnt sich ja sonst nix...
« Antwort #11 am: Juli 19, 2019, 14:12:29 »
Weil automatische Updates so gut klappen, lieben wir doch alle "Windows as a Service"  ;)

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #12 am: Juli 19, 2019, 14:54:41 »
Weil automatische Updates so gut klappen, lieben wir doch alle "Windows as a Service"  ;)

Nich meckan!  >:(

Diesmal ist M$ völlig unschuldig. Der AMD "Treiber" (bei über 400Mb fällt es mir irgendwie schwer von einem solchen zu sprechen) hat ein eigenens, internes, Update System.
Er plärrt von sich aus los und drängt Dir sein Update auf (was dann in die Hose geht, aber das merkst Du dann erst später).

Der Treiber, den Microsoft ausliefert, ist deutlich älter bzw, für diese Kartengeneration noch gar nicht vorhanden.
Lächle! Du kannst sie nicht alle töten!

Mam

  • Hero Member
  • *****
  • Beiträge: 3504
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: MAM gönnt sich ja sonst nix...
« Antwort #13 am: September 11, 2019, 08:00:20 »
Nur mal so als Update: Seit den letzten drei Treiberversionen funktioniert das Update endlich ordnungsgemäs und hinterlässt ein lebens-(und spiel-)fähiges System.
Lächle! Du kannst sie nicht alle töten!

 


www.cypheros.de