TS-Doctor 2.0 www.cypheros.de

Autor Thema: "Sourcefilter konnte sich nicht mit Demuxer verbinden"  (Gelesen 436 mal)

TBone

  • Newbie
  • *
  • Beiträge: 4
  • DVB User
    • Profil anzeigen
"Sourcefilter konnte sich nicht mit Demuxer verbinden"
« am: Februar 14, 2019, 17:33:43 »
Moin, Moin,

ich hatte bislang sehr zufrieden die Testversion benutzt und nun einen Lizenzkey erworben und installiert.
Jetzt habe ich plötzlich die o.g. Fehlermeldung ("Sourcefilter konnte sich nicht mit Demuxer verbinden") beim Start des Schnittfensters.
Ich benutze Windows 7 prof. 64Bit.
Ich vermute es liegt an den Einstellungen unter "Optionen | Vorschau" bei der Auswahl der Filter.
Aktuell steht alles auf Automatik und ich kassiere die Fehlermeldung .
Ändere ich den "Default MPEG Splitter" auf "Windows default (Merit)" gings einigermaßen (das Springen zum nächsten IFrame ging nicht, manchmal kam kein Ton mehr).
Doch nun scheint die zeitliche Reihenfolge meines TS-Streams durcheinandergeraten zu sein: nach ca. ein Viertel des streams kommt das Ende des Films, aber zu dem Ende der Datei habe ich keinen Zugriff mehr - ich kann nicht mehr navigieren. Die Datei allein läßt sich mit VLC aber problemlos abspielen und "Nur Überprüfen" aus dem TS-Doctor fand keine Fehler.
Kann mir jemand helfen?
Über eine Erklärung der besten Filter / Renderer ( gibts da 'ne Reihenfolge??) wäre ich sehr dankbar.

Vielen Dank!
« Letzte Änderung: Februar 14, 2019, 19:27:42 von TBone »

Traxx

  • Hero Member
  • *****
  • Beiträge: 548
  • TSD Heavy User
    • Profil anzeigen
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #1 am: Februar 14, 2019, 18:12:37 »
unter "Optionen/Unterstütze Tools", hast du LAV Filter und Haali Splitter DL und installiert ?
ich hab dann unter "Optionen/Vorschau" alles auf LAV gestellt, teilweise erziehlt man aber beim i-Frame suchen mit Haali Splitter zum teil bessere Ergebnisse, ist Geschmacksache was man bevorzugt.
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

TBone

  • Newbie
  • *
  • Beiträge: 4
  • DVB User
    • Profil anzeigen
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #2 am: Februar 15, 2019, 14:42:05 »
Hallo Traxx,

vielen Dank für die Hilfe! Ich hatte zwar den LAV Filter installiert, aber nun aufgrund Deiner Empfehlung alles auf LAV gestellt und beim Renderer einiges durchprobiert. Ich war überrascht, dass man manchmal 40 ms steppen kann und beim "Enhanced video renderer" auf 20 ms kommt. Beim "default Splitter" steht jetzt bei mir der "Haali Media Splitter". Eine Mischung, die jetzt nicht Deiner Empfehlung entspricht ;-) sorry, aber ohne Dich hätte ich nicht noch mal so viele Optionen durchprobiert und kann jetzt wieder schneiden.
Hurraaa! Danke!
Ich sollte vieleicht noch nachreichen, dass ich SD-Material schneide.
Meine Einstellungen sind aktuell: alle Filter runterladen, die verfügbar sind unter "Optionen | unterstützte Tools". Dann:

Default MPEG Splitter: Haali Media Splitter
Default Audio Filter: LAV Light Video Decoder
Default Video Filter | MPEG2 : LAV Light Video Decoder
Default Video Filter | AVC/H264: LAV Light Video Decoder
Default Video Filter |  HEVC/H265: LAV Light Video Decoder
Default Video Renderer: Enhanced Video Renderer

Nach jedem Wechsel in den Einstellungen, habe ich TS Dochtor neu gestartet, da er oftmals abgestürzt ist oder der Ton weg war.
Diese Einstellungen sind nur stundenlange Rumprobiererei, die Einstellung "Automatik", die Anfänger wie ich bevorzugten, war ein Reinfall.
Vielleicht erbarmt sich doch noch mal jemand ( Hallo Cypheros  :) ) inhaltlich zu erklären, warum einige Kombinationen nicht funktionieren, welche Rangfolge die Automatik-Funktion verfolgt, und gibt eine Empfehlung für eine Anfänger-Konfiguration (ohne auf alle verfügbaren Splitter, Decoder, Renderer eingehen zu müssen).
Gibt es eine "state of the art" Mischung (ggf kommerziell)?

Viele Grüße und allen ein sonniges Wochenende,
TBone


Mam

  • Hero Member
  • *****
  • Beiträge: 3501
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #3 am: Februar 15, 2019, 16:34:16 »
Na ja, leider gibt es keine "Standardeinstellung", die überall und zu jedem Zweck funktioniert.

Du sagst, Du benutzt meistens (oder "nur"?) SD Material, dabei kommen ganz andere Codecs und Formate zum Einsatz, als bei HD und nochmals anders ist UHD.

Das Ganze ist zudem noch stark abhängig von Deiner Grafikkarte, bzw. deren Treiber.

Ich muß Dir allerdings beipflichten "Automatik" ist Unsinn, er müsste wenigstens irgendwo anzeigen, WAS er denn nun wirklich erkoren hat. So tappt man immer im Dunkeln und ich kenne eigentlich keinen hier mehr, der noch auf "Automatik" vertraut.

PS: für SD ist Haali garantiert die richtige Wahl, der ist schon soo alt, der wurde dafür gemacht.
PPS: je "moderner" ein Videoformat ist, desto höher komprimiert ist es auch. Und je höher komprimiert etwas ist, desto ungenauer sind die Sprünge.
Lächle! Du kannst sie nicht alle töten!

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7636
    • Profil anzeigen
    • Cypheros Software Seite
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #4 am: Februar 15, 2019, 18:05:12 »
Beim Splitter bedeutet "AUTOMATIC", dass der Haali-Splitter bei MPEG2 und H264 verwendet wird, bei H265 der LAV, da Haali kein H265 kann.

Bei Audio bedeutet "AUTOMATIC", dass der Audio-Decoder nach eine Prioritätsliste ausgewählt wird, je nachdem welcher davon installiert ist. Bei SD(MPEG2) kannst Du auch den "Cypheros Audio Decoder" nehmen, der ist mit an Board und kann die bei SD üblichen Audio-Formate MP2 und AC3.

Bei Video bedeutet "AUTOMATIC", dass der Video-Decoder nach eine Prioritätsliste ausgewählt wird, je nachdem welcher davon installiert ist. Bei SD(MPEG2) kannst Du auch den "Cypheros MPEG2 Video Decoder" bei MPEG2 nehmen, der ist mit an Board und kann das bei SD übliche Video-Format MPEG2.

Beim Video-Renderer bedeutet "AUTOMATIC", dass bei Windows XP der "Video-Renderer" und bei allen neueren Windows-Versionen der "Enhanced Video-Renderer" verwendet wird. Wird der TS-Doctor unter Linux oder MacOS verwendete, benutzt der TS-Doctor den "TS-Doctor Video Renderer".
Allerdings kommt es vor, dass der "Enhanced Video-Renderer" wegen fehlerhaften Grafikkarten-Treibern (scheint häufiger bei ATI/AMD und Intel zu passieren als bei NVidia) nicht funktioniert, dann muss man per Hand auf einen anderen "Video-Renderer" umstellen.

TBone

  • Newbie
  • *
  • Beiträge: 4
  • DVB User
    • Profil anzeigen
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #5 am: Februar 15, 2019, 22:29:06 »
Dann allen einen herzlichen Dank für die Erhellungen!
Ab März kommt doch tatsächlich hier nach Bayern noch DVB-T2 (wenn ich das zu entscheiden hätte - ich hätte die Barzis auch an letzer Stelle gesetzt  ;D)- dann werde ich den Splitter mal auf LAV ändern.
Das Problem mit den Grafikkartentreibern hatte ich nicht auf dem Schirm - somit entwickelt wohl jeder erfahrene user in diesen "Optionen| Vorschau"-settings seine geheime Mixtur streng nach Omas Rezept zum Weitervererben  :D.

Kiraly-Cutter

  • Full Member
  • ***
  • Beiträge: 143
  • von einer királynő erwarte keinen Dank
    • Profil anzeigen
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #6 am: Februar 15, 2019, 23:04:18 »
Brauchst nichts umzustellen beim Splitter.  ;D
Bei DVB-T2 (HEVC) Aufnahmen wird der Haali Splitter in der Einstellung vom TS Doctor ignoriert und er verwendet automatisch den LAV Splitter.  ;)
VU+ Solo 4K, inspiziert von Cyra.Kiraly@*** für
Nachtvogel
Falkenweg Komplex Nr. -i³
Ruine Falkenburg (Detmold, Germany)

TBone

  • Newbie
  • *
  • Beiträge: 4
  • DVB User
    • Profil anzeigen
Re: "Sourcefilter konnte sich nicht mit Demuxer verbinden"
« Antwort #7 am: Februar 16, 2019, 00:38:58 »
Super. Danke!  :D

 


www.cypheros.de