TS-Doctor 2.0 www.cypheros.de

Autor Thema: Zeitumstellung klappt nicht bei manchen Sendern  (Gelesen 270 mal)

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Zeitumstellung klappt nicht bei manchen Sendern
« am: Oktober 31, 2018, 08:51:10 »
Zeitumstellung klappt nicht bei manchen Sendern, besonders fällt es mir bei den Italienischen Sendern auf, da hab ich fixe wiederkehrende Timer nach Uhrzeit benannt, den TSD seit der Winterzeit Umstellung immer um die 1Stunde verfälscht.
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #1 am: November 06, 2018, 04:21:10 »
Konnte den Fehler eingrenzen liegt wohl an der fehlenden Teletext Analyse, mit wird die Uhrzeit richtig angezeigt, schaltet man sie aus bzw. gibst es keinen Teletext zum analysieren ist es immer  die Sommerzeit die TSD anzeigt.
Bild selbe Aufnahme einmal mit einmal ohne Teletext Analyse.
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7286
    • Profil anzeigen
    • Cypheros Software Seite
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #2 am: November 06, 2018, 12:25:54 »
Das ist wohl ein Bug. Bei Deiner Aufnahme handelt es sich um eine Enigma-Aufnahme und die Zeit wird entweder aus dem Teletext(deutsche Standard-Zeit) oder aus der .eit (UTC) ausgelesen. Die UTC muss entsprechend der Zeitzone für die der Sender ausstrahlt, korrigiert werden. Das scheint nicht korrekt zu funktionieren.

Ich checke das.

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7286
    • Profil anzeigen
    • Cypheros Software Seite
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #3 am: November 07, 2018, 01:26:20 »
Sollte nun korrekt funktionieren, auch ohne Teletext.

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #4 am: November 07, 2018, 04:35:12 »
hm nö unverändert, bei einer Aufnahme wird nun sogar statt die eine stunde später (Sommerzeit) statt der echten Aufnahme zeit 20:04 nun 23:15 angezeigt  :o
Aufnahmen sind von der vu+ duo2 mit vti 13.0.12
siehe Bilder, wieder selbe Aufnahme nur Teletext Verarbeitung & Analyse im TSD ausgeschalten. (was ich immer so eingestellt habe, lädt so deutlich schneller die Files ein.)

EDIT: hab dir von 3 Aufnahmen von heute mit dem Rawcutter die ersten 20mb rausgeschnitten, hab sie dir mit allen Files der vu+ duo2 auf den FTP geladen - zeigt auch mit dem 20mb rawcut Files die falsche Uhrzeit an.
« Letzte Änderung: November 07, 2018, 07:10:30 von Traxx »
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #5 am: November 08, 2018, 23:06:31 »
Halfen die Test Files weiter, Bug gefunden ?, oder brauchst mehr andere Test Files oder längere ? sag was Cypi  :P
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7286
    • Profil anzeigen
    • Cypheros Software Seite
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #6 am: November 09, 2018, 10:11:00 »
Danke, sollte nun zuverlässig laufen.

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #7 am: November 09, 2018, 10:23:25 »
Grade fleißig 1.2.46 am testen, ja die vu+ duo2 Aufnahmen funktionieren jetzt wieder.  8)
dafür hab ich jetzt hier einige Aufnahme meiner Xtrend ET 10000 mit openPLI Image da wird überhaupt kein Datum und Uhrzeit mehr angezeigt  :'( andere Aufnahmen von der selben Box selber Sender funktionieren wieder richtig.  :o

Ich stell dir davon nachher paar Test Files zusammen und lad sie hoch.
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7286
    • Profil anzeigen
    • Cypheros Software Seite
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #8 am: November 09, 2018, 10:44:49 »
Dank, schau ich mir dann an.

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #9 am: November 09, 2018, 10:51:13 »
Files sind am FTP, je 2 die ok sind, und 2 die nicht funktionieren von der selbe Box selben 2 Sender.
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7286
    • Profil anzeigen
    • Cypheros Software Seite
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #10 am: November 09, 2018, 15:36:37 »
Das liegt daran, das nicht alle Index-Dateien vorhanden sind. Dadurch wird die Aufnahme nicht als Enigma-Aufnahme erkannt.

Hab das jetzt geändert, so dass die .ts und die .ts.meta vorhanden sein müssen und entweder die .ts.sc oder die ts.ap, damit die Aufnahmen als Enigma-Aufnahmen erkannt werden.

Traxx

  • Hero Member
  • *****
  • Beiträge: 503
  • TSD Heavy User
    • Profil anzeigen
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #11 am: November 09, 2018, 20:50:36 »
Super Danke.

Ich glaub ich weiß wie das passiert ist, bei den Aufnahmen ist die HDD voll gelaufen und dann wird von der Box keine ts.ap Datei angelegt, ist auch bei den vu+ Boxen mit vti image das selbe.
Die haben zusätzlich 2 schöne Bugs, wenn bei einer vu+ mit vti Image die HDD vollläuft, und eine neue vorher programmierte Timer Aufnahme startet wenn die HDD voll ist, dann stürzt die Box ab und nach dem rebooten ist die gesamte Timer liste leer :o
noch besser ist wenn man von vti den Datenbankbasierende Papierkorb verwendet, dann startet die Box gar nicht mehr, bis man die VTIdb.db löscht.
beides seit einem Jahr im vti Forum bekannt wird nicht gefixt...
https://www.vuplus-support.org/wbb4/index.php?thread/117500-erledigt-duo2-springt-nicht-mehr-an/&postID=1662169#post1662169
ich hab Abhilfe geschaffen in dem ich den Datenbankbasierende Papierkorb deaktiviert habe, und die Timer.xml alle paar Tage auf den PC kopiere als Backup  ;)

« Letzte Änderung: November 09, 2018, 20:52:44 von Traxx »
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7286
    • Profil anzeigen
    • Cypheros Software Seite
Re: Zeitumstellung klappt nicht bei manchen Sendern
« Antwort #12 am: November 10, 2018, 01:13:07 »
Das Problem betrifft nur Aufnahmen ohne EIT(EPG) und deaktivierter Teletext-Verarbeitung.

Vermutlich eher die Ausnahme.

Würde auf jeden Fall von der Deaktivierung der Teletext-Verarbeitung abraten.

 


www.cypheros.de