TS-Doctor 2.0 www.cypheros.de

Autor Thema: Fehler im Ausschnittbereich bei TSD 2.1.33  (Gelesen 463 mal)

Snipstream

  • Full Member
  • ***
  • Beiträge: 124
  • DVB User
    • Profil anzeigen
Fehler im Ausschnittbereich bei TSD 2.1.33
« am: August 24, 2018, 00:26:59 »
Mir ist mehrfach aufgefallen, dass der geschnittene Film im Bereich eines Ausschnittes stark von dem erwarteten Ergebnis abweichen und fehlerhaft sein kann, obwohl alle Schnittpunkte mittels I-Frame erzeugt sind.

Die Fehler sind unabhängig von der Länge der beschnittenen Datei (im Beispiel eine Arte-Aufnahme, die von TSD komplett als fehlerfrei deklariert wird).

                 Hauptschnitt: 00:07:49.740 - 00:10:26.160
     Ausschnitt bei "Blatt": 00:08:29.920 - 00:09:39.520 - entspricht mit Bezug auf die geschnittene Datei: 00:00:40.180 - 00:01:49.780
         Länge 1. Segment: 00:08:29.920 minus 00:07:49.740 = 00:00:40.180
            Ausschnittlänge: 00:09:39.520 minus 00:08:29.920 = 00:01:09.600

Bei der Wiedergabe des geschnittenen Videos gibt es an den Übergangspunkten je nach Wiedergabeprogramm unterschiedliche Fehlersymptome:

DVBViewer, TSDoctor, VLC Mediaplayer: Das letzte Bild des 1. Segmentes 00:00:40.180 wird ca. 2100 ms lang (= 105 Bilder) wie ein Standbild gezeigt, der Zeitzeiger läuft kontinuierlich weiter. Von dem folgenden 2. Segment fehlen dann diese 2100 ms, d.h. die ersten 105 Bilder dieses Segments werden unterschlagen.

Windows Filme & TV, Windows Media Player:  Das 1. Segment endet ca. 0,5 I-Frames früher als im Schnittfenster festgelegt. Ca. 2000 ms nach Beginn des 2. Segments blitzen Bilder vom Ende des 1. Segments kurz auf.

PowerDVD 15: Das 1. Segment endet ca. 0,5 I-Frames früher als im Schnittfenster festgelegt, also 7 bis 8 Bilder früher, das 2. Segment beginnt korrekt.
 
SmartCutter 1.9.4: Das 1. Segment endet 1 I-Frame früher als im Schnittfenster festgelegt. Dann erfolgt ein Flackern, offensichtlich eine Folge der Bildanordnung wie in der folgenden Einzelbild-Analyse beschrieben. 3 Sekunden später bleibt die Wiedergabe hängen und die Zeitanzeige liefert unrealistische Werte.

Analysen der geschnittenen Datei:

Einzelbild-Analyse mit SmartCutter 1.9.4: Das letzte im 1. Segment lückenlos dargestellte Bild 00:00:39.900 entspricht beim Original in TSD dem Bild 00:08:29.640 und endet damit um 1 I-Frame früher als im Schnittfenster festgelegt. Die dadurch fehlenden 15 Bilder werden anschließend im Wechsel mit 15 der sehr dunklen Bilder ab 00:09:39.520 des 2. Segments des Originals wiedergegeben, was das Flacken erklärt.

Einzelbild-Analyse mit TSD 2.1.33: "Blatt" bei 00:00:40.180, das nächste Bild 00:00:40.200 entspricht 00:09:41.580 der Originaldatei. Die Bilder des Originals von 00:09:39.520 bis 00:09:41.580 werden nicht angezeigt, das sind 2060 ms bzw. 103 Bilder. In diesem Bereich wird für jedes Bild das Bild 00:00:40.200 angezeigt.

Fazit:

Schnitte mit TSD können fehlerhaft sein. Wird mit SmartCutter an denselben Schnittpunkten (I-Frame) wie bei TSDoctor geschnitten, gibt es bei keinem der zuvor genannten Programmen eine fehlerhafte Wiedergabe

Cypheros

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7640
    • Profil anzeigen
    • Cypheros Software Seite
Re: Fehler im Ausschnittbereich bei TSD 2.1.33
« Antwort #1 am: August 24, 2018, 13:15:04 »
Wie sehen die Schnitte im Log aus?

Kannst Du die Schnittstelle mit dem RawCutter rausschneiden und uns pr E-Mail schicken an support(ät)cypheros.de? Wir schauen uns die Bildfolge dann mal genauer an.

Traxx

  • Hero Member
  • *****
  • Beiträge: 547
  • TSD Heavy User
    • Profil anzeigen
Re: Fehler im Ausschnittbereich bei TSD 2.1.33
« Antwort #2 am: August 24, 2018, 19:10:08 »
https://cypheros.de/forum_ger2/index.php?topic=1296.msg5860#msg5860
Das Phänomen ist so alt wie TSD selber, schon zu 1.2 Zeiten diskutiert, ich bin deshalb schon lange dazu über gegangen nicht mehr genau zu scheiden sondern lasse 5sek vor & nach den Schnitt Marken.
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

Snipstream

  • Full Member
  • ***
  • Beiträge: 124
  • DVB User
    • Profil anzeigen
Re: Fehler im Ausschnittbereich bei TSD 2.1.33
« Antwort #3 am: August 24, 2018, 19:34:08 »
Beim Herausschneiden mit dem RawCutter erscheint die Fehlermeldung "Raw packet copy exception error!". Ich habe daher das Ende mit dem TSPlayer abgeschnitten.

Per pr E-Mail habe ich Dir die gekürzte Originaldatei und die "Schnittfehler.tsdcuts" zum Einstellen der Schnittpunkte wie in meinem 1. Beitrag.

Die Log-Datei habe ich angehängt.

Anmerkung:
Bei einer anderen Datei habe ebenfalls die zum 1. Problemfall gehörende TSDCUTS angewandt. Auch hier gibt es dasselbe Fehlerbild.

Snipstream

  • Full Member
  • ***
  • Beiträge: 124
  • DVB User
    • Profil anzeigen
Re: Fehler im Ausschnittbereich bei TSD 2.1.33
« Antwort #4 am: August 25, 2018, 00:47:22 »
Das Phänomen ist so alt wie TSD selber, schon zu 1.2 Zeiten diskutiert, ich bin deshalb schon lange dazu über gegangen nicht mehr genau zu scheiden sondern lasse 5sek vor & nach den Schnitt Marken.
Die Probleme bereiten nicht die Anfangs- und Endschnitte, sondern die Ausschnitte.

Ich habe jetzt einen Test gemacht und für das 1. und 2. Segment je eine Datei erzeugt und diese beiden Dateien zusammengesetzt. Das Ergebnis war genau so fehlerhaft wie beim direkten Ausschnitt: 2 s Stillstand am Ende des 1. Segments und für diese Zeit fehlende Dateien des 2. Segments. Die einzelnen Segmente sind aber korrekt. Folglich liegt das Problem nur am Zusammensetzen - egal ob von einzelnen Dateien oder direkt durch einem Schnittauftrag.

Traxx

  • Hero Member
  • *****
  • Beiträge: 547
  • TSD Heavy User
    • Profil anzeigen
Re: Fehler im Ausschnittbereich bei TSD 2.1.33
« Antwort #5 am: August 25, 2018, 01:48:24 »
Zitat
Die Probleme bereiten nicht die Anfangs- und Endschnitte, sondern die Ausschnitte.
Ja ich weiß, es ging bei mir auch nie nur ums Anfang & Ende wegschneiden, sondern immer um die Schnitte mittendrin, und da ist es eben auch bei mir seit Jahren so das mal Fehler wie du sie beschrieben hast da sind egal ob ich am i-Frame schneide oder nicht, mal gibt es keine Fehler mal sind die da, total zufällig ich habe nie einen Grund gefunden warum es ohne Fehler geht und wann nicht, darum lasse ich bei jedem Schnittpunkt ein paar Sekunden Sicherheitspuf­fer.

auch mit den Fehlern ist TSD für mich immer noch das beste um Aufnahmen schnell und einfach zu schneiden, und mit den paar sek. als Puffer zwischen den Schnitten kann ich leben, und hoffen das irgendwann TSD 3.0 kommt der Frame genau schneiden kann ohne die Fehler an den Schnittpunkten  ;)
« Letzte Änderung: August 25, 2018, 02:45:47 von Traxx »
VU+ Solo 4K, Vu+ Duo2, Xtrend ET 10000, Xtrend 7500, TBS-5980 CI

 


www.cypheros.de