TS-Doctor 2.0 www.cypheros.de

Autor Thema: Kann im Schnittfenster den Cursor nicht verschieben und Mausrad nicht benutzen  (Gelesen 602 mal)

BeefJerky

  • Newbie
  • *
  • Beiträge: 9
  • DVB User
    • Profil anzeigen
Hallo alle zusammen!

Ich weiß nicht genau, ob es mit meinem neuen PC zusammenhängt, aber mir ist eben aufgefallen, dass ich im Schnittfenster nicht mehr wie gewohnt navigieren kann. Wenn ich den Cursor mit der linken Maustaste anfasse und verschiebe, wird das neue Videobild erst dann angezeigt, wenn ich die Maustaste loslasse. Während des Verschiebens des Cursors wird die Anzeige nicht aktualisiert. Außerdem kann ich das Mausrad nicht mehr benutzen. Wenn ich am Rad drehe  :D wird das aktuelle Bild ein kleinen wenig heller, aber sonst passiert nichts, der Cursor bewegt sich nicht und ich bewege mich nicht in der Aufnahme vor- oder rückwärts. Das macht das Navigieren ganz schön schwierig...

Ich bin kürzlich von einem Core i5-4570 mit zusätzlicher Geforce 750 GTX auf einen Core i7-8700 ohne zusätzliche Grafikkarte, also mit Intel UHD Graphics 630 umgestiegen. Ohne Neuinstallation. Ich habe lediglich die Nvidia-Treiber deinstalliert und die Intel-Treiber neu installiert. Außerdem habe ich die LAV-Filter auf Version 0.71.0 aktualisiert. Die TS Doctor Version ist 2.1.28.


Wie könnte ich das Problem beseitigen?


Gruß,
Beef



BeefJerky

  • Newbie
  • *
  • Beiträge: 9
  • DVB User
    • Profil anzeigen
Ich weiß nicht genau, ob es mit meinem neuen PC zusammenhängt, aber mir ist eben aufgefallen, dass ich im Schnittfenster nicht mehr wie gewohnt navigieren kann.

Ich sollte vielleicht noch erwähnen, dass es sich um eine öffentlich-rechtliche HD-Satelliten-Aufnahme handelt (1280x720, 50p, h.264).


Danke!

Mam

  • Hero Member
  • *****
  • Beiträge: 3483
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Steck die olle GForce wieder rein  ;D

Die I7 GPU ist ... (hüstel, mummel, drucks rum)... (wie sag ichs meinem Kinde?)  8)
NICHT GEEIGNET  ;D ;D ;D

Nein, ehrlich, das ist Dreck in Tüten, da die meisten Aktionen autonom ablaufen, kriegt der Doc wenig, bis gar keinen Zugriff auf die dekodierten Bilddaten.
Damit ist kein vernünftiger Schnitt möglich.

Am besten abschalten, oder nur als Encoder benutzen.
Lächle! Du kannst sie nicht alle töten!

Snipstream

  • Full Member
  • ***
  • Beiträge: 123
  • DVB User
    • Profil anzeigen
Und wie ist deine Meinung zur Intel HD Graphics 4600?

Mam

  • Hero Member
  • *****
  • Beiträge: 3483
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
ääh, ich hab mich wohl nicht klar genug ausgedrückt, also nochmal deutlich:

Wenn "Intel" und "interne GPU" draufsteht, ist nur die Mülltonne der richtige Einsatzort. Egal, welche Version.

Die Dinger taugen nur als Desktopgrafik, und nicht für Spiele oder Videoanwendungen (man kann damit Videos gucken, aber mehr auch nicht).

Was geht, und was ich hier auch benutze, sind die De-/Encoder Einheiten. Dazu braucht man keinen Monitor mehr anschliessen, aber Programme wie z.B. Handbrake können die Karte trotzdem benutzen.

Der Doc nicht, er encodiert ja auch gar nix.

Das "Problem" besteht hauptsächlich darin, dass die Intel "Karten" ihre Daten gerne für sich behalten. Es hilft nix, dass sie ganz toll Video dekodieren können, wenn man die einzelnen Bilder nicht abrufen kann. Deshalb gibts dann die langen Pausen im Schnittfenster, der Doc wartet auf ein dekodiertes Bild, er kriegt aber keins.

Lächle! Du kannst sie nicht alle töten!

Snipstream

  • Full Member
  • ***
  • Beiträge: 123
  • DVB User
    • Profil anzeigen
Ich kann die Ansichten von Mam leider nicht teilen!

Auf einem i7-4770K-System mit Intel HD Graphics 4600 kann ich folgendes problemlos ausführen:

1. In DVBViewer, VLC MediaPlayer, PowerDVD, Filme & TV etc. kann ich den Schieber bei dauernd gedrückter Maustaste beliebig schnell hin und herschieben, wobei die entsprechenden Scenenbilder angezeigt werden.

Beim TS Dochtor gibt es allerdings Probleme dadurch, dass der Bildaufbau offensichtlich sehr lange dauert, denn bei schnellem Schieben erscheint das zur Schieberposition gehörende Bild erst nach Stillstand der Maus (nicht erst beim Loslassen der Maustaste!), bei langsamem Ziehen besteht dagegen kein erkennbarer Unterschied zu den anderen Programmen. Der TS Doctor hat offensichtlich eine Schwäche in der Darstellungsgeschwindigkeit. Vielleicht lässt sich hier etwas nachbessern.

2. Die von BeefJerky beschriebenen Probleme beim Drehen des Mausrades kann ich auch nicht bestätigen: Jedes Raster schaltet das Video um ein Bild vor oder zurück, ebenso die Links-/Rechts-Pfeiltasten.

Mam

  • Hero Member
  • *****
  • Beiträge: 3483
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
1. In DVBViewer, VLC MediaPlayer, PowerDVD, Filme & TV etc. kann ich den Schieber bei dauernd gedrückter Maustaste beliebig schnell hin und herschieben, wobei die entsprechenden Scenenbilder angezeigt werden.
Was das MAM auch nie in Abrede gestellt hat  ;D

ANZEIGEN kannst Du mit dem Intel Zeuch ALLES, ich rede davon, den Speicher wieder AUSZULESEN per Programm.
Die von Dir erwähnten Abspieler brauchen das alles gar nicht, sie stellen nur eine rechteckige Oberfläche auf dem Bildschirm bereit, den Rest macht die GPU.

Der Doc möchte aber den Inhalt analysieren  (z.B. für Logosuche oder andere Dinge, die Scheff uns nicht verraten wird  ;D), und da sieht es ganz mau aus.
Dank der Content Industrie gibts nicht nur HDCP (Verschlüsselung auf dem Kabel zum Monitor), sondern auch einen "Secure Multimedia Memory Path" (also geschützten Zugriff auf den Speicher mit Inhalten), den Intel sehr sehr genau einhält. Ob die Videos wirklich schützenswert sind, interessiert den Treiber dabei nicht, er schützt einfach alles.

Da die Daten ja alle komprimiert sind, reicht es für eine genaue Positionsbestimmung nicht aus, mitzuprotokollieren wieviel man in den Dekoder reingejagt hat. Und wenn der nicht zurückmeldet, wo er gerade ist, dann wirds sehr schwer für den Programmierer...
Lächle! Du kannst sie nicht alle töten!

BeefJerky

  • Newbie
  • *
  • Beiträge: 9
  • DVB User
    • Profil anzeigen
Hmh, ok und nun?

Ist die neuere  Intel UHD Graphics 630 weniger leistungsfähig, als die  Intel HD Graphics 4600? Und wenn ich Snipstream richtig verstanden habe, dann müsste doch wohl wenigstens mein Mausrad funktionieren? Es stimmt, ich muss die Maustaste beim Verschieben des Cursors nicht erst loslassen. Es reicht, wenn ich anhalte und warte. Nach etwa einer Sekunde kommt das neue Bild. Das Mausrad funktioniert aber definitiv gar nicht, es kommt nie eine neues Bild, obwohl das Mausrad in anderen Anwendungen ganz normal funktioniert. Ich hatte ehrlich gesagt nicht gedacht, dass mir eine alte Geforce 750 GTX in einem System mit Core i7-8700 noch etwas bringt (außer höherem Stromverbrauch). Soll ich die wirklich wieder einbauen, oder hakt es irgendwo anders im System?

Dankeschön!
Beef

Mam

  • Hero Member
  • *****
  • Beiträge: 3483
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Ist die neuere  Intel UHD Graphics 630 weniger leistungsfähig, als die  Intel HD Graphics 4600?
Nein  ;D (irgendwie versteht mich keiner, wie sag ichs meinem Fellow-User???  >:( ;D)
natürlich nicht, aber das ist gar nicht der Punkt  ;D

Grundsätzlich gilt: "je moderner, desto ungeeigneter".
Warum?
Weil immer mehr "Contentanbieter" darauf bestehen, dass die ausgegebenen Videos gegen Kopieren geschützt sind. Für UHD muss man schon zwingend HDCP 2.2 anbieten und den bereits erwähnten Secure Memory Path, sonst weigern sich Lieferanten wie Netflix & Co ihre Videos auf Geräten mit dem-und-dem Chip überhaupt anzbieten.
Also müssen Intel, AMD und NVidea dafür sorgen, dass ihre GPUs "sauber" sind, sonst bricht ihnen ein großer Markt weg.
Deshalb können modernere Kisten eigentlich meist weniger, als zuvor und treiben einen Riesenaufwand damit, Dich vom Zugriff abzuhalten.

"Große" Programme (bzw. deren Hersteller) können sich mit Lizenzen freikaufen und erhalten Zugriff auf die benötigten Funktionen. Cypheros kann sich ja noch nichtmal armseelige Dolby Lizenzen leisten, er ist darauf angewiesen, dass irgendwas schon noch frei zugänglich bleibt.

Hier gehts nicht um Technik, sondern um Geld, viel Geld...
Lächle! Du kannst sie nicht alle töten!

BeefJerky

  • Newbie
  • *
  • Beiträge: 9
  • DVB User
    • Profil anzeigen
Weil immer mehr "Contentanbieter" darauf bestehen, dass die ausgegebenen Videos gegen Kopieren geschützt sind. Für UHD muss man schon zwingend HDCP 2.2 anbieten und den bereits erwähnten Secure Memory Path, sonst weigern sich Lieferanten wie Netflix & Co ihre Videos auf Geräten mit dem-und-dem Chip überhaupt anzbieten.

Ok, das verstehe ich zwar, hatte aber gedacht, dass das in letzter Instanz auch eine Frage des jeweiligen Streams ist und das Aufnahmen der öffentlich-rechtlichen Sender von diesen Einschränkungen nicht betroffen sind. Und die Trägheit des Schnittfensters und das Nichtfunktionieren des Mausrades ist bei allen Aufnahmen das gleiche, auch bei ganz alten Aufnahmen der Öffis in SD. Wenn es stimmt, was Du beschreibst, wie wäre es dann mit selbsterstellten Aufnahmen aus einem HD Camcorder? Ist da die Leistung mit moderneren Chips auch so eingeschränkt?

Irgendwelche weiteren Ideen, warum in TS Doctor mein Mausrad streikt?

Dankeschön,
Beef

Mam

  • Hero Member
  • *****
  • Beiträge: 3483
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Du bist süß (aka naiv)  ;D
Der Karte ist es "§$"egal, was sie da gerade wiedergibt, sie geht einfach immer vom Worst Case aus und schützt alles, was ihr in die GPU kommt.  ;D

Bei Mausrädern habe ich keine Ahnung, sowas benutz ich nicht :-) ("zu meiner Zeit hatten Mäuse meist nur eine oder gar keine Tasten, dafür aber Schwänze und scharfe Zähne"  :-*) )
Allerdings würde ich da mal vermuten, dass Du Dir irgendein "optimierungs Tool" eingefangen hast und das meint, die Maussignale gehörten sicherlich umformatiert und "verbessert".
Pflichtgemäs hab ich es gerade mal ausprobiert, wenn ich am Rad drehe, geht es wohl Einzelbildweise vor und zurück (ich weis aber nicht, ob das so richtig und gewollt ist).
Wenn das normal ist, würde ich sagen, Deine beiden Probleme sind nur ein gemeinsames. Sprünge dauern ewig, Einzelbildschritt geht gar nicht.

Wenn Du die LAV Filter benutzt, versuch mal spasseshalber, die Hardwarebeschleunigung zu deaktivieren und probier es dann nochmal. Bei NVidea meint Scheff ja, sie solle AN sein, ich hab hier AMD, da gehts auch mit AN, bei Intel weis ich nicht. Muss man probieren.


Lächle! Du kannst sie nicht alle töten!

BeefJerky

  • Newbie
  • *
  • Beiträge: 9
  • DVB User
    • Profil anzeigen
Ja, ich habe noch ein bisschen rumprobiert. Das Mausrad funktioniert beim Nach-"unten"-rollen, überhaupt nicht. Drehe ich das Rad nach "oben", bewege ich mich ganz furchtbar langsam (!) vorwärts durch die Aufnahme. Also das Mausrad arbeitet schlecht und verkehrt herum! Es ist eine Logitech M705 Marathon Maus zusammen mit der SetPoint Software des gleichen Herstellers. Das hat aber auch so schon mal funktioniert im TSD. Trotzdem habe ich testweise die SetPoint Software mal deinstalliert, keine Besserung. Ich hatte die LAV-Filter kürzlich auf 0.71.0 aktualisiert und bin deshalb zurück auf die Version 0.70.2 gegangen, die ich vorher drauf hatte, keine Besserung. Deaktivierung der Hardware-Beschleunigung, keine Besserung. Andere Optimierungstools gibt's nicht. Mein Gefühl sagt mir, dass es am TSD selbst liegt. Kann ich eigentlich irgendwie auf eine etwas ältere Version vom TSD zurückgehen?

Gruß,
Beef

Kiraly-Cutter

  • Full Member
  • ***
  • Beiträge: 139
  • von einer királynő erwarte keinen Dank
    • Profil anzeigen
Im Link die gewünschte Version eintragen (ersetzen):
http://www.cypheros.de/download.php?f=TSDoctor2_Ger_2.1.27.exe
VU+ Solo 4K, inspiziert von Cyra.Kiraly@*** für
Nachtvogel
Falkenweg Komplex Nr. -i³
Ruine Falkenburg (Detmold, Germany)

Mam

  • Hero Member
  • *****
  • Beiträge: 3483
  • ich hab keine Macken - das sind Special Effects!
    • Profil anzeigen
Also, ich würdmal sagen "Vergiß das Mausrad"
Das ist nur ein Symptom, Dein Problem liegt eindeutig darin, dass Du gar nicht vernünftig vor und zurück positionieren kannst, ob mit Maus, Tastatur oder Zeitangabe. Es wird wohl alles schnarchen.

Und nein, es liegt nicht an der Doc Version, bei Dir ist eindeutig was mit Codecs / Splitter usw. im Argen. Vielleicht hat die Installation der neuen Karte ja alte Einstellungen/Programme gelöscht?
Installier diese Teile nochmal neu, boote einmal und hoffe  ;D
Lächle! Du kannst sie nicht alle töten!

BeefJerky

  • Newbie
  • *
  • Beiträge: 9
  • DVB User
    • Profil anzeigen
Im Link die gewünschte Version eintragen (ersetzen):
http://www.cypheros.de/download.php?f=TSDoctor2_Ger_2.1.27.exe

Jupp, vielen Dank! Zurück auf Version 2.1.12, keine Besserung! Schon verrückt...
Steige gerade noch um auf die aktuellste Grafiktreiber-Version von Intel...

 


www.cypheros.de