TS-Doctor 2.0 www.cypheros.de

Beiträge anzeigen

Diese Sektion erlaubt es ihnen alle Beiträge dieses Mitglieds zu sehen. Beachten sie, dass sie nur solche Beiträge sehen können, zu denen sie auch Zugriffsrechte haben.


Themen - Djfe

Seiten: [1] 2 3 ... 11
1
Plauder-Ecke / ATSC 3.0
« am: April 15, 2017, 16:10:09 »
Hab mir gerade folgenden Artikel durchgelesen:
http://atsc.org/newsletter/atsc-3-0-where-we-stand/#.WPIa5J5CSAN

Dachte das könnte auch andere hier interessieren.

Zielgeräte umfassen im neuen Standard auch Smartphones/Tablets.

Die Übertragung wird über IP mit UDP/TCP und ISO BMFF laufen. (Angleichung, weg von Transportstreams, hin zu dem was eh schon alle sprechen: IP)
letzteres scheint eine Art paketisiertes (aufgeteilt chunks) mov/mp4 zu sein

sowohl multicast als auch unicast sollen möglich sein, vlt. senden die manche der Streams auch übers Internet
Standard wäre derselbe, aber es wäre uneingeschränkt VoD möglich und nur der Empfangsweg würde sich unterscheiden

Codec ist wie zu erwarten hevc
von SD über interlaced bis hin zu 4k progressive 120fps scheint alles unterstützt zu werden

Es soll/wird inkompatibel zum bisherigen Standard sein
man will wohl einmal neu anfangen und ungehindert spezifizieren.

In Südkorea wird ATSC 3.0 anscheinend seit Februar diesen Jahres bereits ausgestrahlt.

Wann die USA folgen, ist mir nicht bekannt.

Bin gespannt, ob die DVB plant, irgendwann ebenfalls von Mpeg2 wegzumigrieren.
So skeptisch, wie aktuell soviele zu sein scheinen, was neue Standards betrifft, könnte ich mir aber eine derartige Umstellung hierzulande erstmal noch nicht vorstellen.
und hevc wird ja schon über diverse Kanäle gesendet

2
Allgemeines zum Board / letztes AC3 Patent läuft aus
« am: März 19, 2017, 23:57:43 »
Hi,

hab gerade mitbekommen, dass heute Nacht scheinbar das letzte Patent ausläuft, das mit Dolby Digital (AC3) zu tun hat

Fall es euch interessiert, hier  steht mehr ;)

3
Allgemeines zum Board / go to full site funktioniert nicht
« am: Januar 15, 2017, 03:32:51 »
Zunächst: das neue mobile Design ist klasse :)
ich werde es vermutlich auch nicht mehr abschalten

Der Go to full site button funktioniert jedoch unter Firefox for Android noch nicht
(den Browser anzuweisen einen desktop user-agent zu nutzen geht aber einwandfrei)

edit: Chrome ist auch betroffen

4
Plauder-Ecke / neues Foren Theme
« am: Dezember 21, 2016, 07:14:09 »
Hi,

gibt es bei dem neuen Theme eine Möglichkeit "neue" Beiträge/Threads mit neuen Nachrichten besser hervorzuheben
ein "neu" hinter dem Thread-Title hebt es nicht sonderlich hervor :/

ansonsten find ich das neue Theme ok, es sind aber eigentlich vor allem andere Farben, der Rest ist gleich
der Hintergrund erinnert an den des Fritz!Box Interfaces

die Paddings für Text und co. in der Liste der Forenübersicht oder eher deren Fehlen stören etwas, aber es betrifft ja nur die eine Stelle

5
Der UPNP Öffnen Dialog macht Probleme.
Nachdem man ein paar Dateien geöffnet hat, lassen sich damit keine neue Dateien mehr öffnen
Ein Doppelklick auf eine Datei schließt nur den Dialog, aber mehr nicht :/
(man sieht auch das der Button rechts unten ausgegraut ist, der Dialog denkt also, dass man gar keine Datei ausgewählt hat)

die Inhalte der Ordner sind um 1 nach oben verschoben
der Inhalt von "Filme to fix" wird im Ordner "aktuelle Musik" angezeigt
(nur die Unterordner von "Filme to fix" sind korrekt)
Nur ein Neustart des TSDs nach jedem Fixvorgang schafft abhilfe (oder man nutzt stattdessen den Explorerdialog)

dieser Bug ist kritisch, bitte fixe ihn! :)

Das Screencapture liegt auf deinem FTP

6
Aufzeichnungen mit dem PC / Suche eine günstige DVB-T2 Karte
« am: Juni 05, 2016, 05:02:16 »
Hi,

könnt ihr mir eine preiswerte DVB-T2 (HD) pcie Karte empfehlen, mit der man hier in Deutschland empfangen kann?
Oder ist ein Receiver mit PVR günstiger?

Ich würde mir das gerne mal selbst ansehen.
Ob es durch H.265 einen qualitativen Unterschied zu DVB-S2 bei den ÖR gibt, selbst wenn nur hochskaliert wird usw.

Grüße,
Djfe

7
Hi Cypheros,
Ich hab heute ein Problem im Schnittfenster selbst erlebt, dass hier schonmal jemand hatte (ich find den Thread nur gerade nicht)

Das Schnittfenster klappt nur auf einem Bildschirm und das Hauptfenster des TSDs muss auch vor dem Öffnen des Schnittfenster auf diesem Bildschirm sein.

Ich muss es noch testen, indem ich ein Kabel umstecke, aber es hängt ziemlich sicher damit zusammen, dass ich zwei Grafikkarten verwende.
Eine pro Bildschirm:
Der Hauptschirm hängt an meiner Nvidia (miniDP) und der Zweitschirm an meiner Intel Onboard Grafikkarte (HDMI).
Hauptgrafikkarte (UEFI Einstellung) ist die Nvidiakarte

02:01:20.749: OS: Windows 10 (Version 10.0, Build 0, 64-Bit-Edition)
02:01:20.749: Graphic card: NVIDIA GeForce GTX 980 (DISPLAY1) nvd3dum.dll 10.18.13.6472
            : Intel(R) HD Graphics 530 (DISPLAY5) igdumdim32.dll 20.19.15.4285
02:01:20.749: Resolution  : 2560 x 1440 (32Bit) 96 DPI
02:01:20.749: Monitors    : 2
02:01:21.268: Cypheros TS Doctor 2.0.29
            : DirectX Version: 11.2
            : Selected audio filter: LAV Audio Decoder
            : Selected video filter: LAV Video Decoder
            : Selected Mpeg splitter: Haali Media Splitter (AR)
02:01:21.268: File: G:\Game of Thrones\20160425 1929 - Sky Atlantic HD - Game Of Thrones The Story So Far.ts
02:01:21.268: INIT PLAYBACK
02:01:21.268: Creating playback thread
02:01:21.288: Successfully created Graph Builder
02:01:21.288: Successfully created Media Control
02:01:21.288: Successfully created Media Event
02:01:21.293: Adding filters to the graph
02:01:21.313: Try to add FileSource TS-Doctor Filesource
02:01:21.334: Successfully created new filter TS-Doctor Filesource
02:01:21.354: Successfully queried file source
02:01:21.375: Control interface TS-Doctor Filesource assigned
02:01:21.416: Successfully loaded file
02:01:21.416: Successfully added TS-Doctor Filesource to graph
02:01:21.437: FileSource TS-Doctor Filesource added
02:01:21.451: Enumerating filters: found 32 categories
02:01:21.472: Loading filter Haali Media Splitter (AR) and adding to graph successfully completed
02:01:21.496: Loading filter LAV Video Decoder and adding to graph successfully completed
02:01:21.516: Loading filter LAV Audio Decoder and adding to graph successfully completed
02:01:21.538: Loading filter Enhanced Video Renderer and adding to graph successfully completed
02:01:21.538: Getting EVR display control
02:01:21.662: Successfully created sample grabber
02:01:21.662: Successfully added sample grabber to graph
02:01:21.871: Connected (direct) direct TS-Doctor Filesource.Output -> Haali Media Splitter (AR).Input
02:01:21.871: Successfully created FrameTypeDetect Filter
02:01:21.871: Successfully added FrameTypeDetect Filter to graph
02:01:21.891: Connected (direct) direct Haali Media Splitter (AR).Video -> TS-Doctor FrameType Detector.Input
02:01:21.912: Connected (direct) direct TS-Doctor FrameType Detector.Output -> LAV Video Decoder.Input
02:01:21.912: Connected (direct) direct LAV Video Decoder.Output -> Cypheros FrameCache.XForm In
02:01:21.933: Connected (direct) direct Cypheros FrameCache.XForm Out -> Enhanced Video Renderer.EVR Input0
02:01:21.933: Connected sample grabber to video renderer
02:01:21.933: Already Connected LAV Video Decoder -> Cypheros FrameCache
02:01:21.933: Try to render demuxer output pins
02:01:21.935: Rendering source pin: Audio
02:01:21.956: Successfully rendered file
02:01:21.977: Default DirectSound Device
            : Enhanced Video Renderer
            : LAV Audio Decoder
            : Cypheros FrameCache
            : LAV Video Decoder
            : TS-Doctor FrameType Detector
            : Haali Media Splitter (AR)
            : TS-Doctor Filesource
02:01:21.977: Successfully created Media Seeking
02:01:22.005: Successfully created Basic Video
02:01:22.005: Successfully created Basic Audio
02:01:22.007: Successfully created Media Position
02:01:22.007: Starting playback
02:01:22.177: Pausing playback
02:01:22.177: Video duration: 01:35:01.800
02:01:22.198: StreamSelect activated
02:01:22.198: Failed to get average time per frame ($80004002)
02:01:22.198: Failed to get video size ($80004002)
02:01:22.198: Video size: 1920 x 1088
02:01:26.865: Resuming playback
02:01:46.156: MediaControl paused
02:01:46.356: Resuming playback
02:01:57.203: Stopping
02:01:57.203: Stopping playback thread
02:01:57.203: MediaControl execute stop
02:01:57.203: Destroying I-Frame thread
02:01:57.203: I-Frame thread destroyed
02:01:57.203: Stopping MediaControl
02:01:57.209: MediaControl stopped
02:01:57.209: Playback thread stopped
02:01:57.209: Terminating playback thread
02:01:57.309: Destroying playback thread
02:01:57.309: Destroying graph
02:01:57.309: Releasing frame grabber filter
02:01:57.310: Frame type filter released
02:01:57.310: Releasing frame grabber filter
02:01:57.329: Frame type filter released
02:01:57.330: MediaControl released
02:01:57.330: StreamSelect released
02:01:57.330: MediaPosition released
02:01:57.330: BasicAudio released
02:01:57.330: BasicVideo released
02:01:57.330: IMFDisplayControl released
02:01:57.330: Event released
02:01:57.330: MediaSeeking released
02:01:57.330: pFileSourceControl released
02:01:57.330: pFileSourceFilter released
02:01:57.339: pSource removed from graph
02:01:57.339: pSource released
02:01:57.339: Removing all filters
02:01:57.339: Try to remove Default DirectSound Device
02:01:57.340: Removing filter:Default DirectSound Device : OK
02:01:57.340: Releasing: Default DirectSound Device
02:01:57.340: Releasing: DONE [0]
02:01:57.340: Try to remove Enhanced Video Renderer
02:01:57.340: Removing filter:Enhanced Video Renderer : OK
02:01:57.340: Releasing: Enhanced Video Renderer
02:01:57.340: Releasing: DONE [1]
02:01:57.340: Try to remove LAV Video Decoder
02:01:57.340: Removing filter:LAV Video Decoder : OK
02:01:57.340: Releasing: LAV Video Decoder
02:01:57.340: Releasing: DONE [0]
02:01:57.340: Try to remove Haali Media Splitter (AR)
02:01:57.340: Removing filter:Haali Media Splitter (AR) : OK
02:01:57.341: Releasing: Haali Media Splitter (AR)
02:01:57.341: Releasing: DONE [0]
02:01:57.341: Try to remove LAV Audio Decoder
02:01:57.341: Removing filter:LAV Audio Decoder : OK
02:01:57.341: Releasing: LAV Audio Decoder
02:01:57.341: Releasing: DONE [0]
02:01:57.342: Graph released
02:01:57.348: Playback thread destroyed
02:01:57.351: Playback thread terminated (1)

Die Beschreibung des Problems:
Wenn ich das Schnittfenster auf den zweiten Schirm ziehe, wird das Bild schwarz. Die Wiedergabe des Tons funktioniert aber einwandfrei.
Mit MPC-HC tritt das Problem zwar nicht auf

aber wenn ich als Video Decoder im TSD Merit nehme, bekomme ich auf beiden Bildschirmen ein Bild.
Irgendwie friert nur Windows gewissermaßen für 1-2 Sekunden ein (bis auf die Maus), wenn ich das Schnittfenster von Bildschirm 1 nach 2 ziehe (anklicken des TSDs oder anderer Fenster macht nichts mehr)
das Einfrieren passiert bei MPC-HC aber nicht

am Splitter hängt es scheinbar nicht, es tritt sowohl mit LAV als auch Haali auf.


Wenn das Bild im TSD einmal schwarz ist, bringt ein zurückziehen auf den Hauptschirm auch nichts mehr -> ich muss das Schnittfenster neu öffnen

wenn ich den TSD zuerst auf den Zweitbildschirm ziehe und dann den TSD starte, bekomme ich nur ein schwarzes Bild
bzw. ich sehe weiterhin das Bild was beim Generieren der Previews angezeigt wird (scheint noch in irgendeinem Buffer zu hängen, denn wenn ich den TSD vergrößere/verkleinere sehe ich im Abspielfenster Artefakte der GUI Elemente, die dort vorher waren)


Jedenfalls, das ganze ist kein wirkliches Problem für mich, ich wollte dich nur darüber informieren, dass es das Problem gibt und es ggf. auch bei Leuten mit einem solchen Setup auftreten wird (weil viele eine Onboardgrafikkarte von Intel haben)
Der Grund, warum ich das Setup überhaupt einsetze, ist, dass ich meine Hauptkarte nicht durch den Zweitbildschirm belasten möchte.
ist aber auch nur ein Luxusproblem. Ich will das mein PC auch die 144Hz des Monitors erreicht (in Spielen).

8
Moin Cypheros.
Wenn du Zeit hast, wäre es super, wenn du folgende Meldung aus dem Log entfernen oder sie im Log zusammenfassen könntest:
Zero Byte Stuffing not followed by PayloadStart

das log findest du im Anhang
falls dich die Dateiendung wundert: so speichert das Merlin Image auf meiner DM800 HD die Timeshifts ab

9
TS-Doctor 2.x / Aufteilen auf mehrere Dateien, Error Setting Path
« am: April 11, 2016, 08:38:56 »
wenn ich beim Aufteilen auf mehrere Dateien den Dateinamen "2.ts" nehme, schmeißt der TSD nachher im Hauptfenster den Error
"Error Setting Path", obwohl 2.ts nach meinem Verständnis ein gültiger Dateiname ist

wird da irgendwo automatisches Casting betrieben, sodass 2 als Zahl statt als String erkannt wird? (nur ne Vermutung)

EDIT:
zunächst kam der Fehler nur beim Ändern des Dateinamens auf 2, ein ändern auf einen anderen Dateinamen hat geholfen
nach ein paar Mal hin und her, kam der Error aber nun bei jedem Dateinamen

ein Neustart des TSDs hat das Problem behoben

10
Man sollte die Dateinamen beim Aufteilen auf mehrere Dateien mit Enter bestätigen können (der OK Button sollte durch Enter gedrückt werden)
dann kann man schneller arbeiten ;)

11
TS-Doctor 2.x / .eit .meta Verschlüsselung
« am: April 06, 2016, 22:37:05 »
wenn der TSD Verschlüsselung entfernen muss (z.B. bei Select), werden .eit und .meta noch nicht mitkopiert

zunächst kam die Meldung: teilweise verschlüsselt
nach einem Scan: Stream beginnt verschlüsselt, Anfang entfernen und erneut öffnen? (oder so ähnlich)

außerdem steht am Anfang des Logs:
Opening file G:\Filme\xy.ts
Multiple files: Merging virtually
File 1 : G:\Filme\xy.ts

Dabei ist es nur eine Datei?

(TSD 2.0.24)

12
TS-Doctor 2.x / Crash beim Startup, Tempfiles löschen
« am: April 04, 2016, 21:05:51 »
Ich bekomme ab und zu beim Startup noch den Hinweis, dass Tempdateien übrig sind (vermutlich von OCR oder VA Debug)
das Problem an der Geschichte ist, dass er wenn ich auf löschen klicke die Hälfte der Male wegcrasht

vielleicht warte ich zu lange (20 Sekunden), zumindestens hab ich das Gefühl, dass es weniger crasht, wenn ich sofort auf löschen klicke

zuerst bekomme ich:
Name der fehlerhaften Anwendung: TSDoctor.exe, Version: 2.0.24.0, Zeitstempel: 0x57013673
Name des fehlerhaften Moduls: unknown, Version: 0.0.0.0, Zeitstempel: 0x00000000
Ausnahmecode: 0xc0000005
Fehleroffset: 0x077c66ff
ID des fehlerhaften Prozesses: 0x1adc
Startzeit der fehlerhaften Anwendung: 0x01d18ea43ae1de24
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Cypheros\TSDoctor2\TSDoctor.exe
Pfad des fehlerhaften Moduls: unknown
Berichtskennung: 0bc08d87-bb2a-4fa9-9944-9228bfab2f6f
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:
und einige Sekunden später
Name der fehlerhaften Anwendung: TSDoctor.exe, Version: 2.0.24.0, Zeitstempel: 0x57013673
Name des fehlerhaften Moduls: unknown, Version: 0.0.0.0, Zeitstempel: 0x00000000
Ausnahmecode: 0xc000041d
Fehleroffset: 0x077c66ff
ID des fehlerhaften Prozesses: 0x1adc
Startzeit der fehlerhaften Anwendung: 0x01d18ea43ae1de24
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Cypheros\TSDoctor2\TSDoctor.exe
Pfad des fehlerhaften Moduls: unknown
Berichtskennung: bda6fd6b-679b-484f-aec9-10c2b77ea94d
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:
In der Ereignisanzeige

13
Der Link zur Beta auf der TSD 2 Download Page (http://www.cypheros.de/tsdoctor2_downloads.html)
Führt zum Betabereich vom TSD 1
also http://www.cypheros.de/tsdoctor_beta.html
statt http://www.cypheros.de/tsdoctor2_beta.html

EDIT:
selbes gilt für den alte Versionen Link

14
...funktioniert leider noch nicht

Wäre dankbar, wenn das irgendwann mal eingefügt wird :)

Außerdem sollten .eit und .meta zumindestens für die erste der x-Dateien noch mitkopiert werden, da sind sie ja noch akkurat ;)

15
TS-Doctor 2.x / UI Gedöns
« am: Februar 26, 2016, 17:20:55 »
@Cypheros
ein paar Unschönheiten an der UI mit keiner Priorität, die du ggf. bei einem der nächsten Updates einschieben könntest

1. es gibt noch immer das Problem, dass die fette Schrift eines markierten Eintrags zu breit ist, wenn man die Settings in die Breite zieht
2-4. einige Menüeinträge mit dotted border, der nicht zum Skin passt
5. wenn man keinen Eintrag ausgewählt hat, hat der Eintrag der ersten PID beim Öffnen des Fenster graue Schrift auf weißem Grund
6. man könnte hier ein wenig Padding einfügen

Seiten: [1] 2 3 ... 11

www.cypheros.de