TS Datei in mkv Problem Remuxen

Begonnen von Bondi007, Januar 01, 2023, 18:16:42

« vorheriges - nächstes »

Bondi007

Hallo zusammen, ich habe da mal ein paar Fragen bzgl. TS Datei Remuxen. Ich gehe wie immer folgendermaßen vor. Ich lese die Aufnahme, von meine Dreambox ein. Wähle die Audiospuren aus die ich behalten möchte. Schneide die Aufnahme dann über den TS Doctor zurecht. Dann über den TS Doctor Button (Neue Datei erzeugen) das klappt alles wunderbar. Nun möchte ich halt aus der fertigen TS Datei eine mkv machen. Das mache ich dann über TS Doctor (Experten Werkzeuge – TS Remuxer) Die Log der remuxed hänge ich euch mal hier im Post dran. Was bedeuten den Die Warnungen und die missing frame Sachen der AC3 spur? Habe irgendwie das Gefühl, das die fertige Datei nicht wirklich Synchron ist. Oder täusche ich mich da?

ZitatBroadcast standard selected: DVB
Broadcast standard detected: DVB
PES WARNING: PID 17D4 scrambled 100,00%
First valid video frame found at PTS: 19:14:13.975
Backup H264 parameter sets.
PCR discontinuity at PCR: 19:14:12.683 69252683ms
Start writing PID $17DE at PTS: 19:14:13.975 as video
Start writing PID $17E8 at PTS: 19:14:13.989 aligned to video PID $17DE, remaining delay 14 ms
First AC3 frame PID $17EA at PTS: 19:14:14.062 / frame size: 1792 / 2.0/48kHz
AC3 missing frame on PID $17EA at PTS: 19:14:14.030 silence inserted
AC3 missing frame on PID $17EA at PTS: 19:14:13.998 silence inserted
AC3 missing frame on PID $17EA at PTS: 19:14:13.966 silence inserted
AC3 silence inserted on PID $17EA at PTS: 19:14:13.934
Start writing PID $17EA at PTS: 19:14:13.966 aligned to video PID $17DE, remaining delay -10 ms
Demuxing DONE


Mam

Zitat von: Bondi007 am Januar 01, 2023, 18:16:42Habe irgendwie das Gefühl, das die fertige Datei nicht wirklich Synchron ist. Oder täusche ich mich da?
Nicht wirklich  ;D
Ton und Bild werden ja versetzt in dem Stream gesendet, geschnitten wird aber immer am Bild (sonst hässliche Klötzchen an den Übergängen). Der Ton eilt aber dem Bild voraus (die Idee dabei: Ton ist kleiner, braucht weniger Platz, also können die Abspieler den mit wenig Aufwand puffern und dann "zur richtigen Zeit" ausgeben, wenn das passende Bild vorbeikommt), deshalb fehlt bei jedem Schnittpunkt immer ein wenig Ton. Da man aber nicht weis, wielange das letzte Tonpaket zurückliegt, kann man nur würfeln um die Lücke mit "Stille" aufzufüllen.
Und wenn das Würfeln schlecht war (und viele Schnittpunkte vorhanden sind) kommt man langsam an die magische Grenze von 100ms ran, ab der empfindet man den Ton als "nicht lippensynchron".

Bei Deiner Aufnahme hat er geschätzt, dass 14ms auszugleichen sind, und entsprechende Pausen eingebaut. Beim Speichern war die Verzögerung aber nur noch 10ms (Du hast wohl ein paar Tonspuren weggelassen?), so dass das nicht mehr so ganz in Einklang zu bringen ist.

Das Problem liegt eigentlich in dem Format "TS" (wobei MKV kein anderes Format ist, sondern nur eine andere Verpackung), das enthält einige Timer die Zappern erlauben sollen, nach dem Umschalten möglichst schnell einen Aufsetzpunkt zu finden.
Wenn Du statt dem Remuxen neu encoden würdest (z.B. mit Handbrake), dann käme "PS" raus, das hat diese Timer nicht. Ist aber mehr Aufwand und dauert deutlich länger.

Bondi007

er macht es ja komischerweise nur bei der AC3 Spur. bei der mpeg Tonspur habe ich diese meldung in der log nicht. Also ich kann auch ohne die AC3 Spur leben. hat er das also aus der log her, wie in Post 1 korrigiert. oder ist da immer noch ne leichte verzögerung am ende drinne? oder kann man da grundsätzlich anders vorgehen, mit dem ganzen. das so was nicht passiert?

Mam

Zitat von: Bondi007 am Januar 01, 2023, 21:16:08der mpeg Tonspur habe ich diese meldung in der log nicht
Keine Meldung heißt nicht, dass es nicht passiert  ;D
AC3 enthält Prüfsummen, da fallen Fehler auf. Bei MPEG nicht.


www.cypheros.de