First PCR not found!

Begonnen von JonBest, August 31, 2018, 09:25:25

« vorheriges - nächstes »


Hi, trying out a trial of this software and whenever I try to open a TS recording I get the following errors. I have tried this on multiple video recordings with the same result?

The video plays without any issues and I can open it in other editing software such as Videoredo? Here is an example of the log output:

Supported TS source filter found  : TS Doctor FileSource (on)
Supported splitter filter found   : Haali Media Splitter, LAV Light Splitter
Supported audio filter found      : LAV Light Audio Decoder
Supported Mpeg video filter found : LAV Light Video Decoder, CyberLink Video/SP Decoder
Supported H.264 video filter found : LAV Light Video Decoder, CyberLink Video Decoder (PDVD13), Microsoft DTV-DVD Video Decoder
Supported H.265 video filter found : LAV Light Video Decoder
Supported video renderer found    : Video Renderer, Haali Video Renderer, Enhanced Video Renderer

Channel database : 7747 channels, 7 satellites [Thor 0.8°W, Astra 19.2°E, Astra 23.5°E, Astra 28.2°E, Astra 4.9°E, Hellas Sat 39°E, Hotbird 13°E]
Teletext database: 295 channels, version 18.4.30

File size: 3800301748
Packets  : 20214371

Found 1 fill packets at end
Broadcast standard selected: DVB
Broadcast standard detected: DVB
PES WARNING: PID 0101 DataAlignmentIndicator = 0

0     (0000): 2%   = PAT
4096  (1000): 2%   = PMT
256   (0100): 90%  = H264 Video (PES_StreamID E0 = Video_Stream_0) {00000001} [PCR,PTS,DTS]
17    (0011): 0%   = SDT,BAT,ST
257   (0101): 4%   = AAC Audio (PES_StreamID C0 = Audio_Stream_0) {56E1A499} [PTS][PESLength]

Selecting PMT with PID 4096 (1000) at position 00000002

  stream_type              : 27 = AVC video stream as defined in ITU-T Rec. H.264 | ISO/IEC 14496-10 Video
  elementary_pid           : 256 (0100)
  ES_info_length           : 0

  stream_type              : 15 = ISO/IEC 13818-7 AAC with ADTS transport syntax (AAC ADTS)
  elementary_pid           : 257 (0101)
  ES_info_length           : 0

PCR PID is 256 (0100)

searching for channel: SID=1, TID=1, VPID=256
                       found channel 731.  Service01, FFmpeg [Thor 0.8°W]

service_id $0001 = Service01

Stream is not starting with a correct PCR timer, timer skipped :00:00:00.700 > 00:00:10.700
Stream is not starting with a correct PCR timer, timer skipped :00:00:10.700 > 00:00:13.180
Stream is not starting with a correct PCR timer, timer skipped :00:00:13.180 > 00:00:18.700
Stream is not starting with a correct PCR timer, timer skipped :00:00:18.700 > 00:00:21.540
Stream is not starting with a correct PCR timer, timer skipped :00:00:21.540 > 00:00:24.780
Stream is not starting with a correct PCR timer, timer skipped :00:00:24.780 > 00:00:27.780
Stream is not starting with a correct PCR timer, timer skipped :00:00:27.780 > 00:00:32.620

First PCR not found!


This is not a valid MPEG-Stream because the PCR intervals are too long. The maximum allowed time between two PCRs is 100ms. In your case it's up to 10000ms.


Hi Cypheros, thanks for replying. Is there nothing that can be done, will it simply not work with TS-Doctor? Here is the output of Mediainfo: It appears to be an mpeg stream and is a .ts file?

Format                                   : MPEG-TS
File size                                : 3.54 GiB
Duration                                 : 2 h 5 min
Overall bit rate mode                    : Variable
Overall bit rate                         : 4 050 kb/s

ID                                       : 256 (0x100)
Menu ID                                  : 1 (0x1)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, RefFrames               : 4 frames
Codec ID                                 : 27
Duration                                 : 2 h 5 min
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Variable
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive

ID                                       : 257 (0x101)
Menu ID                                  : 1 (0x1)
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format version                           : Version 4
Format profile                           : LC
Muxing mode                              : ADTS
Codec ID                                 : 15
Duration                                 : 2 h 5 min
Bit rate mode                            : Variable
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Delay relative to video                  : -63 ms

ID                                       : 4096 (0x1000)
Menu ID                                  : 1 (0x1)
Duration                                 : 2 h 5 min
List                                     : 256 (0x100) (AVC) / 257 (0x101) (AAC)
Service name                             : Service01
Service provider                         : FFmpeg
Service type                             : digital television

Thanks, Jon


Hi Jon, it's a strange problem, we never stumbled over before.
Could you offer a short sample (~10MB) of the beginning of the file? You could use the RawCutter under Tools to make a copy of the first 10MB of the file. Maybe we can analyse the problem and work out a solution.

You can send the sample to support(et) . 


No problem, sample sent to referencing this topic.


Thanks, the recording has indeed PCR values out of specs. We will try to find a way to correct that problems.


The distance between PCRs are out of specs. Coming version 2.1.35 will offer you to fix the PCR problems. After PCR problems fixed, the file will be accepted.


Thanks Cypheros, is their a timescale on the next version please?


Only a few hours up to a few days.



Thanks, just tried this and it worked.

A pity it has to re-create the whole file but its definitely better than not working at all & is now a viable product for my needs.

I'm very impressed with your response to the issue. Thanks again :)